const regex = /(?<=\d)\s+(?=\d)|\+(?=\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)\\s+(?=\\d)|\\+(?=\\d)', 'g')
const str = `hello +70 888 777 1 1 3 thisa `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);