import Foundation
let pattern = #"(?<=\d)\s+(?=\d)|\+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hello +70 888 777 1 1 3 thisa "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)