#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)pa=[a-z0-9]*@[a-z]*"
Local $sString = "upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg=="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")