// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)pa=[a-z0-9]*@[a-z]*").unwrap();
let string = "upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg==";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}