$re = '/pa=[a-z0-9]*@[a-z]*/mi';
$str = 'upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg==';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);