const regex = /pa=[a-z0-9]*@[a-z]*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('pa=[a-z0-9]*@[a-z]*', 'gmi')
const str = `upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg==`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}