re = /pa=[a-z0-9]*@[a-z]*/mi
str = 'upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg=='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end