import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "pa=[a-z0-9]*@[a-z]*";
final String string = "upi://pay?mode=02&pa=Q37433781@ybl&purpose=00&mc=7299&pn=PhonePeMerchant&orgid=180001&sign=MEQCIEPYrGM6osGyjp103pjog+zWijsL/NiLwltYJuyBcqxtAiBBKxeov1YvtePQIRE6/SPimFIyBCbOZLUE2LsGKDMgbg==";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}