#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(.*?\)(?![^\n()]*\))"
Local $sString = "stuff" & @CRLF & _
"stuff (single_word)" & @CRLF & _
"stuff (single_word) more stuff" & @CRLF & _
"stuff (multiple words)" & @CRLF & _
"stuff (words (inside (other) words) eww)" & @CRLF & _
"stuff (first group) stuff (second group) more stuff" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")