re = /\(.*?\)(?![^\n()]*\))/
str = 'stuff
stuff (single_word)
stuff (single_word) more stuff
stuff (multiple words)
stuff (words (inside (other) words) eww)
stuff (first group) stuff (second group) more stuff
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end