import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(.*?\\)(?![^\\n()]*\\))";
final String string = "stuff\n"
+ "stuff (single_word)\n"
+ "stuff (single_word) more stuff\n"
+ "stuff (multiple words)\n"
+ "stuff (words (inside (other) words) eww)\n"
+ "stuff (first group) stuff (second group) more stuff\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}