$re = '/\(.*?\)(?![^\n()]*\))/';
$str = 'stuff
stuff (single_word)
stuff (single_word) more stuff
stuff (multiple words)
stuff (words (inside (other) words) eww)
stuff (first group) stuff (second group) more stuff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);