const regex = new RegExp('\\(.*?\\)(?![^\\n()]*\\))', 'g')
const str = `stuff
stuff (single_word)
stuff (single_word) more stuff
stuff (multiple words)
stuff (words (inside (other) words) eww)
stuff (first group) stuff (second group) more stuff
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}