import re
regex = re.compile(r"\(.*?\)(?![^\n()]*\))")
test_str = ("stuff\n"
"stuff (single_word)\n"
"stuff (single_word) more stuff\n"
"stuff (multiple words)\n"
"stuff (words (inside (other) words) eww)\n"
"stuff (first group) stuff (second group) more stuff\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")