#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)"
Local $sString = "TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)