re = /(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)/
str = 'TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result