use strict;
my $str = 'TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL';
my $regex = qr/(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";