using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)";
string substitution = @"$1";
string input = @"TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}