$re = '/(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)/';
$str = 'TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;