using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^builds/job/(?P<job_name>(larch|thunder))/start/(?P<start_date>[0-9]+)/end/(?P<end_date>[0-9]+)/$";
string input = @"builds/job/larch/start/123/end/123/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}