package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^builds/job/(?P<job_name>(larch|thunder))/start/(?P<start_date>[0-9]+)/end/(?P<end_date>[0-9]+)/$`)
var str = `builds/job/larch/start/123/end/123/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}