$re = '/^builds/job/(?P<job_name>(larch|thunder))/start/(?P<start_date>[0-9]+)/end/(?P<end_date>[0-9]+)/$/';
$str = 'builds/job/larch/start/123/end/123/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);