// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^builds/job/(?P<job_name>(larch|thunder))/start/(?P<start_date>[0-9]+)/end/(?P<end_date>[0-9]+)/$").unwrap();
let string = "builds/job/larch/start/123/end/123/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}