import Foundation
let pattern = #"^builds/job/(?P<job_name>(larch|thunder))/start/(?P<start_date>[0-9]+)/end/(?P<end_date>[0-9]+)/$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"builds/job/larch/start/123/end/123/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}