#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^.*|\n\s*\S+)|\S+(?= .*\n)"
Local $sString = "67 4 -8 5 13" & @CRLF & _
" 9 13 42 4 -7" & @CRLF & _
" 1 1 3 -9 29" & @CRLF & _
"16 99 8 77 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")