import Foundation
let pattern = #"(^.*|\n\s*\S+)|\S+(?= .*\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
67 4 -8 5 13
9 13 42 4 -7
1 1 3 -9 29
16 99 8 77 0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)