import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*|\\n\\s*\\S+)|\\S+(?= .*\\n)";
final String string = "67 4 -8 5 13\n"
+ " 9 13 42 4 -7\n"
+ " 1 1 3 -9 29\n"
+ "16 99 8 77 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}