use strict;
my $str = '67 4 -8 5 13
9 13 42 4 -7
1 1 3 -9 29
16 99 8 77 0';
my $regex = qr/(^.*|\n\s*\S+)|\S+(?= .*\n)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}