const regex = /(^.*|\n\s*\S+)|\S+(?= .*\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*|\\n\\s*\\S+)|\\S+(?= .*\\n)', 'g')
const str = `67 4 -8 5 13
9 13 42 4 -7
1 1 3 -9 29
16 99 8 77 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}