$re = '/(^.*|\n\s*\S+)|\S+(?= .*\n)/';
$str = '67 4 -8 5 13
9 13 42 4 -7
1 1 3 -9 29
16 99 8 77 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);