import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s)#[a-zA-Z0-9][\\w-]*\\b";
final String string = "#Beginning of string matches,\n\n"
+ "#Word matches.\n\n"
+ "#word_1 and #word-1 matches.\n\n"
+ "They match even if they are followed by a non-word like #word\" or #word\" or #word.\n\n"
+ "#_words beggining width underscore or with #-hypen don't match.\n\n"
+ "Brok#en words don't match either.\n\n"
+ "Should we match these cases? -#word \"#word ,#word\n\n"
+ "Hash from urls do not match: http://site/#hash\n\n"
+ "Neither ?#hash nor -#hash\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}