import Foundation
let pattern = ##"(^|\s)#[a-zA-Z0-9][\w-]*\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#Beginning of string matches,
#Word matches.
#word_1 and #word-1 matches.
They match even if they are followed by a non-word like #word" or #word" or #word.
#_words beggining width underscore or with #-hypen don't match.
Brok#en words don't match either.
Should we match these cases? -#word "#word ,#word
Hash from urls do not match: http://site/#hash
Neither ?#hash nor -#hash
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)