// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|\s)#[a-zA-Z0-9][\w-]*\b").unwrap();
let string = "#Beginning of string matches,
#Word matches.
#word_1 and #word-1 matches.
They match even if they are followed by a non-word like #word\" or #word\" or #word.
#_words beggining width underscore or with #-hypen don't match.
Brok#en words don't match either.
Should we match these cases? -#word \"#word ,#word
Hash from urls do not match: http://site/#hash
Neither ?#hash nor -#hash
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}