# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\s)#[a-zA-Z0-9][\w-]*\b"
test_str = ("#Beginning of string matches,\n\n"
"#Word matches.\n\n"
"#word_1 and #word-1 matches.\n\n"
"They match even if they are followed by a non-word like #word\" or #word\" or #word.\n\n"
"#_words beggining width underscore or with #-hypen don't match.\n\n"
"Brok#en words don't match either.\n\n"
"Should we match these cases? -#word \"#word ,#word\n\n"
"Hash from urls do not match: http://site/#hash\n\n"
"Neither ?#hash nor -#hash\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.