const regex = /(^|\s)#[a-zA-Z0-9][\w-]*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)#[a-zA-Z0-9][\\w-]*\\b', 'g')
const str = `#Beginning of string matches,
#Word matches.
#word_1 and #word-1 matches.
They match even if they are followed by a non-word like #word" or #word" or #word.
#_words beggining width underscore or with #-hypen don't match.
Brok#en words don't match either.
Should we match these cases? -#word "#word ,#word
Hash from urls do not match: http://site/#hash
Neither ?#hash nor -#hash
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}