re = /(^|\s)#[a-zA-Z0-9][\w-]*\b/
str = '#Beginning of string matches,
#Word matches.
#word_1 and #word-1 matches.
They match even if they are followed by a non-word like #word" or #word" or #word.
#_words beggining width underscore or with #-hypen don\'t match.
Brok#en words don\'t match either.
Should we match these cases? -#word "#word ,#word
Hash from urls do not match: http://site/#hash
Neither ?#hash nor -#hash
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end