const regex = /PT(.*?$)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PT(.*?$)', 'm')
const str = `abced @ 1.20689\\nLS @ 1.22000\\nPT1 @ 1.1900\\nPT2 @ 1.1800
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}