import re
regex = re.compile(r"PT(.*?$)", flags=re.MULTILINE)
test_str = ("abced @ 1.20689\\nLS @ 1.22000\\nPT1 @ 1.1900\\nPT2 @ 1.1800\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")