// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)PT(.*?$)").unwrap();
let string = "abced @ 1.20689\\nLS @ 1.22000\\nPT1 @ 1.1900\\nPT2 @ 1.1800
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}