#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx) ^ # start of line" & @CRLF & _
" {\w+} # any word character wrapped by curly brackets" & @CRLF & _
" \s\S+ # space followed by one or more Not-spaces" & @CRLF & _
" \s\S+ # space followed by one or more Not-spaces" & @CRLF & _
" \s-\s # space-dash-space" & @CRLF & _
" ( # --First match group:" & @CRLF & _
" New\s\w+ # ‘New’ followed by space and one or more word chars" & @CRLF & _
" \s-\s # space-dash-space" & @CRLF & _
" New\s\w+ # ‘New’ followed by space and one or more word chars" & @CRLF & _
" ) # --END First match group" & @CRLF & _
" \s* # one-or-more spaces (you can remove this, I think)" & @CRLF & _
" $ # end of line" & @CRLF & _
""
Local $sString = "{BANANAS} 2015/02/03 16:10 - Old look - Old Design" & @CRLF & _
"{BALOONS} 2015/02/03 16:23 - New look - New Design" & @CRLF & _
"{ORANGES} 2015/02/03 16:30 - Old look - Old Design" & @CRLF & _
"{BALOONS} 2015/02/03 16:50 - New look - New Design" & @CRLF & _
"{CARS} 2015/02/03 16:55 - New link - New Creation"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")