import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ^ # start of line\n"
+ " \\{\\w+\\} # any word character wrapped by curly brackets\n"
+ " \\s\\S+ # space followed by one or more Not-spaces\n"
+ " \\s\\S+ # space followed by one or more Not-spaces\n"
+ " \\s-\\s # space-dash-space\n"
+ " ( # --First match group:\n"
+ " New\\s\\w+ # ‘New’ followed by space and one or more word chars\n"
+ " \\s-\\s # space-dash-space\n"
+ " New\\s\\w+ # ‘New’ followed by space and one or more word chars\n"
+ " ) # --END First match group\n"
+ " \\s* # one-or-more spaces (you can remove this, I think)\n"
+ " $ # end of line\n";
final String string = "{BANANAS} 2015/02/03 16:10 - Old look - Old Design\n"
+ "{BALOONS} 2015/02/03 16:23 - New look - New Design\n"
+ "{ORANGES} 2015/02/03 16:30 - Old look - Old Design\n"
+ "{BALOONS} 2015/02/03 16:50 - New look - New Design\n"
+ "{CARS} 2015/02/03 16:55 - New link - New Creation";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}