package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx) ^ # start of line
{\w+} # any word character wrapped by curly brackets
\s\S+ # space followed by one or more Not-spaces
\s\S+ # space followed by one or more Not-spaces
\s-\s # space-dash-space
( # --First match group:
New\s\w+ # ‘New’ followed by space and one or more word chars
\s-\s # space-dash-space
New\s\w+ # ‘New’ followed by space and one or more word chars
) # --END First match group
\s* # one-or-more spaces (you can remove this, I think)
$ # end of line
`)
var str = `{BANANAS} 2015/02/03 16:10 - Old look - Old Design
{BALOONS} 2015/02/03 16:23 - New look - New Design
{ORANGES} 2015/02/03 16:30 - Old look - Old Design
{BALOONS} 2015/02/03 16:50 - New look - New Design
{CARS} 2015/02/03 16:55 - New link - New Creation`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}