import re
regex = re.compile(r"""
^ # start of line
{\w+} # any word character wrapped by curly brackets
\s\S+ # space followed by one or more Not-spaces
\s\S+ # space followed by one or more Not-spaces
\s-\s # space-dash-space
( # --First match group:
New\s\w+ # ‘New’ followed by space and one or more word chars
\s-\s # space-dash-space
New\s\w+ # ‘New’ followed by space and one or more word chars
) # --END First match group
\s* # one-or-more spaces (you can remove this, I think)
$ # end of line
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("{BANANAS} 2015/02/03 16:10 - Old look - Old Design\n"
"{BALOONS} 2015/02/03 16:23 - New look - New Design\n"
"{ORANGES} 2015/02/03 16:30 - Old look - Old Design\n"
"{BALOONS} 2015/02/03 16:50 - New look - New Design\n"
"{CARS} 2015/02/03 16:55 - New link - New Creation")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")