use strict;
my $str = '{BANANAS} 2015/02/03 16:10 - Old look - Old Design
{BALOONS} 2015/02/03 16:23 - New look - New Design
{ORANGES} 2015/02/03 16:30 - Old look - Old Design
{BALOONS} 2015/02/03 16:50 - New look - New Design
{CARS} 2015/02/03 16:55 - New link - New Creation';
my $regex = qr/ ^ # start of line
{\w+} # any word character wrapped by curly brackets
\s\S+ # space followed by one or more Not-spaces
\s\S+ # space followed by one or more Not-spaces
\s-\s # space-dash-space
( # --First match group:
New\s\w+ # ‘New’ followed by space and one or more word chars
\s-\s # space-dash-space
New\s\w+ # ‘New’ followed by space and one or more word chars
) # --END First match group
\s* # one-or-more spaces (you can remove this, I think)
$ # end of line
/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}