# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!or|and|not)([a-z0-9*.])+/$0[45]/ig;t' <<< " Germany or (Indian, Tech*)
Germany and (Indian, Tech*)
Germany not (Indian, Tech*)"