use strict;
my $str = ' Germany or (Indian, Tech*)
Germany and (Indian, Tech*)
Germany not (Indian, Tech*)';
my $regex = qr/\b(?!or|and|not)([a-z0-9*.])+/ip;
my $subst = '$0[45]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";