using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!or|and|not)([a-z0-9*.])+";
string substitution = @"$0[45]";
string input = @" Germany or (Indian, Tech*)
Germany and (Indian, Tech*)
Germany not (Indian, Tech*)";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}