import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!or|and|not)([a-z0-9*.])+";
final String string = " Germany or (Indian, Tech*)\n"
+ "Germany and (Indian, Tech*)\n"
+ "Germany not (Indian, Tech*)";
final String subst = "$0[45]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}