import Foundation
let pattern = #"\b(?!or|and|not)([a-z0-9*.])+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Germany or (Indian, Tech*)
Germany and (Indian, Tech*)
Germany not (Indian, Tech*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0[45]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)