import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!^\\s|\\s$)[a-z0-9\\s]){1,20}$";
final String string = "12345678901234567890\n"
+ "12345678901234567890foo\n"
+ " 12345\n"
+ "12345 12345\n"
+ "12345 \n"
+ "a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}